View Issue Details

IDProjectCategoryView StatusLast Update
0000003WebPImage Decodingpublic2020-11-16 13:19
ReporterPonki1986 Assigned Tooliver  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformWinUAEOSAmigaOSOS Version3.9.4
Product Version45.1 
Fixed in Version45.2 
Summary0000003: WebP images are not displayed.
DescriptionFor example, MultiView displays a error that is not enough memory. However, other programs simply do not display images. The other warp datatypes are working fine.
TagsNo tags attached.

Activities

oliver

oliver

2020-11-14 16:04

administrator   ~0000004

Can you attach a sample image or post the website URL? Also, does SnoopDos mention any failures? I'm specifically thinking of the math libraries that are required. It is probably best to also try the 68020 version of WarpWebP with WinUAE as some versions of WinUAE may have broken FPU emulation and/or 64-bit math operations.
Ponki1986

Ponki1986

2020-11-14 17:07

reporter   ~0000005

Thank you for your answer. Unfortunately, the version for 68020 also doesn't work, MultiView shows the same error. I increased the amount of UAEGFX memory, but that didn't help. SnoopDOS does not show errors but shows a request for a WarpWebP.prefs file, so the file type is recognized. Maybe it's the patch's fault. I use FBlit, FText, MCP, CopyMemAIO, NoMoreDiv0, StackAttack2, VisualPrefs, MemTrailer, TAGLife, SystemPatch, and the math libraries for WinUAE available on Aminet. An example file that I wanted to display is https://pl.m.wikipedia.org/wiki/File:Johnrogershousemay2020.webp Generally it's strange, because if something was wrong in the system, the other Warp Datatypes would also not work, and only WebP makes problem.
oliver

oliver

2020-11-14 18:04

administrator   ~0000006

Maybe, but WebP is heavy on floating point and 64-bit integer usage, unlike all the other WarpDTs which are mostly 32-bit integer only, with the exception of TIFF.

Which version of picture.datatype are you using? I think I may have found the issue.
oliver

oliver

2020-11-14 18:13

administrator   ~0000007

Please try the attached 020 test version to see if it makes any difference.
WarpWebP_020_test.lha (47,535 bytes)
Ponki1986

Ponki1986

2020-11-15 11:01

reporter   ~0000008

I checked the test version you provided. Everything works fine, I am attaching a photo from MultiView.
IMG_20201115_114834.jpg (1,337,160 bytes)
oliver

oliver

2020-11-16 13:19

administrator   ~0000009

Thanks for testing and confirming. It is a fix that all the other datatypes have had in for a long time - not sure why I omitted it from the WebP datatype!

Basically, some picture.datatype versions do not bother to clear the error code to indicate success, which was the case for the one from p96 initially - maybe the OS 3.5/3.9 and/or OS3.1.4 ones behave this way too.

I'll release an official update to fix this soon.

Issue History

Date Modified Username Field Change
2020-11-10 17:39 Ponki1986 New Issue
2020-11-14 16:04 oliver Assigned To => oliver
2020-11-14 16:04 oliver Status new => acknowledged
2020-11-14 16:04 oliver Note Added: 0000004
2020-11-14 17:07 Ponki1986 Note Added: 0000005
2020-11-14 18:04 oliver Note Added: 0000006
2020-11-14 18:13 oliver Note Added: 0000007
2020-11-14 18:13 oliver File Added: WarpWebP_020_test.lha
2020-11-15 11:01 Ponki1986 Note Added: 0000008
2020-11-15 11:01 Ponki1986 File Added: IMG_20201115_114834.jpg
2020-11-16 13:19 oliver Status acknowledged => resolved
2020-11-16 13:19 oliver Resolution open => fixed
2020-11-16 13:19 oliver Fixed in Version => 45.2
2020-11-16 13:19 oliver Note Added: 0000009