View Issue Details

IDProjectCategoryView StatusLast Update
0000002PNGImage Decodingpublic2020-05-11 08:30
Reportertwiard Assigned Tooliver  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version45.23 
Summary0000002: truncated image decoding
Descriptionbonjour

when I decode the .PNG attached, I see only a part of the picture as seen on the screenshot attached

thank you
TagsNo tags attached.

Activities

twiard

twiard

2020-05-10 08:46

reporter  

20200510_103805.jpg (1,767,405 bytes)
twiard

twiard

2020-05-10 08:47

reporter  

amigalogocheck.png (57,137 bytes)   
amigalogocheck.png (57,137 bytes)   
oliver

oliver

2020-05-10 13:05

administrator   ~0000002

Thanks for the report - I've traced this back and the problem first started occurring in WarpPNG 45.18 (45.17 and earlier were ok). There is a stream decode error appearing in zlib, but I have yet to determine if the problem is located in zlib or libpng - unfortunately, both were updated in WarpPNG 45.18. I'll hopefully find a fix soon.
oliver

oliver

2020-05-11 08:30

administrator   ~0000003

This has been fixed for the next release. Technically, there is an error in that PNG file (zlib window size has been set to the incorrect size) which can be fixed with pngfix. But, I've reverted WarpPNG to the old libpng 1.5.x behaviour so it will be able to read all images with this error. IBrowse inherited this issue too and that is fixed too also, for the next release.

Issue History

Date Modified Username Field Change
2020-05-10 08:44 twiard New Issue
2020-05-10 08:46 twiard File Added: 20200510_103805.jpg
2020-05-10 08:47 twiard File Added: amigalogocheck.png
2020-05-10 13:05 oliver Assigned To => oliver
2020-05-10 13:05 oliver Status new => confirmed
2020-05-10 13:05 oliver Note Added: 0000002
2020-05-11 08:30 oliver Status confirmed => resolved
2020-05-11 08:30 oliver Resolution open => fixed
2020-05-11 08:30 oliver Fixed in Version => 45.23
2020-05-11 08:30 oliver Note Added: 0000003